==> Synchronizing chroot copy [/chroot/armv7h/root] -> [build]...done
==> Making package: tomb 2.9-1 (Fri Feb 19 15:11:56 2021)
==> Retrieving sources...
  -> Found Tomb-2.9.tar.gz
==> WARNING: Skipping verification of source file PGP signatures.
==> Validating source files with sha512sums...
    Tomb-2.9.tar.gz ... Passed
Host and machine ids are equal (2b3dd5a7c7b749ff93431232041f2429): refusing to link journals
==> Making package: tomb 2.9-1 (Fri 19 Feb 2021 03:12:18 PM EST)
==> Checking runtime dependencies...
==> Installing missing dependencies...
resolving dependencies...
looking for conflicting packages...
warning: dependency cycle detected:
warning: harfbuzz will be installed before its freetype2 dependency

Packages (43) atk-2.36.0-1  avahi-0.8+15+ge8a3dd0-3  cairo-1.17.4-3
              desktop-file-utils-0.26-1  fontconfig-2:2.13.91+48+gfcb0420-2
              freetype2-2.10.4-1  fribidi-1.0.10-1  gdk-pixbuf2-2.42.2-1
              graphite-1:1.3.14-1  gtk-update-icon-cache-1:4.0.3-1
              harfbuzz-2.7.4-1  hicolor-icon-theme-0.17-2  libcups-1:2.3.3op2-1
              libdaemon-0.14-5  libdatrie-0.2.12-2  libjpeg-turbo-2.0.6-1
              libpng-1.6.37-3  librsvg-2:2.50.3-1  libthai-0.1.28-2
              libtiff-4.2.0-1  libx11-1.7.0-3  libxau-1.0.9-3  libxcb-1.14-1
              libxcomposite-0.4.5-3  libxcursor-1.2.0-2  libxdamage-1.1.5-3
              libxdmcp-1.1.3-3  libxext-1.3.4-3  libxfixes-5.0.3-4
              libxft-2.3.3-2  libxi-1.7.10-3  libxinerama-1.1.4-3
              libxrandr-1.5.2-3  libxrender-0.9.10-4  lzo-2.10-3
              pango-1:1.48.2-1  pixman-0.40.0-1
              shared-mime-info-2.0+57+gc1d1c70-1  xcb-proto-1.14.1-3
              xorgproto-2020.1-1  gtk2-2.24.33-1  libnotify-0.7.9-1  zsh-5.8-1

Total Download Size:   13.58 MiB
Total Installed Size:  98.76 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
downloading lzo-2.10-3-armv7h.pkg.tar.xz...
downloading zsh-5.8-1-armv7h.pkg.tar.xz...
downloading atk-2.36.0-1-armv7h.pkg.tar.xz...
downloading libdatrie-0.2.12-2-armv7h.pkg.tar.xz...
downloading libthai-0.1.28-2-armv7h.pkg.tar.xz...
downloading pixman-0.40.0-1-armv7h.pkg.tar.xz...
downloading cairo-1.17.4-3-armv7h.pkg.tar.xz...
downloading fribidi-1.0.10-1-armv7h.pkg.tar.xz...
downloading pango-1:1.48.2-1-armv7h.pkg.tar.xz...
downloading libxfixes-5.0.3-4-armv7h.pkg.tar.xz...
downloading libxcursor-1.2.0-2-armv7h.pkg.tar.xz...
downloading libxinerama-1.1.4-3-armv7h.pkg.tar.xz...
downloading libxrandr-1.5.2-3-armv7h.pkg.tar.xz...
downloading libxi-1.7.10-3-armv7h.pkg.tar.xz...
downloading libxcomposite-0.4.5-3-armv7h.pkg.tar.xz...
downloading libxdamage-1.1.5-3-armv7h.pkg.tar.xz...
downloading shared-mime-info-2.0+57+gc1d1c70-1-armv7h.pkg.tar.xz...
downloading libjpeg-turbo-2.0.6-1-armv7h.pkg.tar.xz...
downloading libtiff-4.2.0-1-armv7h.pkg.tar.xz...
downloading libdaemon-0.14-5-armv7h.pkg.tar.xz...
downloading avahi-0.8+15+ge8a3dd0-3-armv7h.pkg.tar.xz...
downloading libcups-1:2.3.3op2-1-armv7h.pkg.tar.xz...
downloading gdk-pixbuf2-2.42.2-1-armv7h.pkg.tar.xz...
downloading librsvg-2:2.50.3-1-armv7h.pkg.tar.xz...
downloading hicolor-icon-theme-0.17-2-any.pkg.tar.xz...
downloading gtk-update-icon-cache-1:4.0.3-1-armv7h.pkg.tar.xz...
downloading desktop-file-utils-0.26-1-armv7h.pkg.tar.xz...
downloading gtk2-2.24.33-1-armv7h.pkg.tar.xz...
downloading libnotify-0.7.9-1-armv7h.pkg.tar.xz...
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
checking available disk space...
:: Processing package changes...
installing zsh...
installing atk...
installing libdatrie...
installing libthai...
installing lzo...
installing libpng...
installing graphite...
installing harfbuzz...
Optional dependencies for harfbuzz
    cairo: hb-view program [pending]
installing freetype2...
installing fontconfig...
Rebuilding fontconfig cache... done.
installing xcb-proto...
installing libxdmcp...
installing libxau...
installing libxcb...
installing xorgproto...
installing libx11...
installing libxext...
installing libxrender...
installing pixman...
installing cairo...
installing libxft...
installing fribidi...
installing pango...
installing libxfixes...
installing libxcursor...
Optional dependencies for libxcursor
    gnome-themes-standard: fallback icon theme
installing libxinerama...
installing libxrandr...
installing libxi...
installing libxcomposite...
installing libxdamage...
installing shared-mime-info...
installing libjpeg-turbo...
installing libtiff...
Optional dependencies for libtiff
    freeglut: for using tiffgt
installing libdaemon...
installing avahi...
Optional dependencies for avahi
    gtk3: avahi-discover, avahi-discover-standalone, bshell, bssh, bvnc
    qt5-base: qt5 bindings
    libevent: libevent bindings
    nss-mdns: NSS support for mDNS
    python-twisted: avahi-bookmarks
    python-gobject: avahi-bookmarks, avahi-discover
    python-dbus: avahi-bookmarks, avahi-discover
installing libcups...
installing gdk-pixbuf2...
installing librsvg...
installing hicolor-icon-theme...
installing gtk-update-icon-cache...
installing desktop-file-utils...
installing gtk2...
Optional dependencies for gtk2
    gnome-themes-standard: Default widget theme
    adwaita-icon-theme: Default icon theme
    python2: gtk-builder-convert
installing libnotify...
:: Running post-transaction hooks...
(1/9) Creating system user accounts...
Creating group avahi with gid 977.
Creating user avahi (Avahi mDNS/DNS-SD daemon) with uid 977 and gid 977.
(2/9) Reloading system manager configuration...
  Skipped: Current root is not booted.
(3/9) Arming ConditionNeedsUpdate...
(4/9) Reloading system bus configuration...
  Skipped: Current root is not booted.
(5/9) Probing GDK-Pixbuf loader modules...
(6/9) Probing GTK2 input method modules...
(7/9) Updating icon theme caches...
(8/9) Updating the desktop file MIME type cache...
(9/9) Updating the MIME type database...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found Tomb-2.9.tar.gz
==> WARNING: Skipping all source file integrity checks.
==> Extracting sources...
  -> Extracting Tomb-2.9.tar.gz with bsdtar
==> Starting prepare()...
==> Starting build()...
cc -I. `pkg-config --cflags libnotify gtk+-2.0` -march=armv7-a -mfloat-abi=hard -mfpu=vfpv3-d16 -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -c tomb-gtk-tray.c
In file included from /usr/include/gtk-2.0/gtk/gtkobject.h:37,
                 from /usr/include/gtk-2.0/gtk/gtkwidget.h:36,
                 from /usr/include/gtk-2.0/gtk/gtkcontainer.h:35,
                 from /usr/include/gtk-2.0/gtk/gtkbin.h:35,
                 from /usr/include/gtk-2.0/gtk/gtkwindow.h:36,
                 from /usr/include/gtk-2.0/gtk/gtkdialog.h:35,
                 from /usr/include/gtk-2.0/gtk/gtkaboutdialog.h:32,
                 from /usr/include/gtk-2.0/gtk/gtk.h:33,
                 from tomb-gtk-tray.c:30:
/usr/include/gtk-2.0/gtk/gtktypeutils.h:236:1: warning: GTypeDebugFlags’ is deprecated []8;;https://gcc.gnu.org/onlinedocs/gcc/Warning-Options.html#index-Wdeprecated-declarations-Wdeprecated-declarations]8;;]
  236 | void            gtk_type_init   (GTypeDebugFlags    debug_flags);
      | ^~~~
In file included from /usr/include/glib-2.0/gobject/gobject.h:24,
                 from /usr/include/glib-2.0/gobject/gbinding.h:29,
                 from /usr/include/glib-2.0/glib-object.h:22,
                 from /usr/include/glib-2.0/gio/gioenums.h:28,
                 from /usr/include/glib-2.0/gio/giotypes.h:28,
                 from /usr/include/glib-2.0/gio/gio.h:26,
                 from /usr/include/gtk-2.0/gdk/gdkapplaunchcontext.h:30,
                 from /usr/include/gtk-2.0/gdk/gdk.h:32,
                 from /usr/include/gtk-2.0/gtk/gtk.h:32,
                 from tomb-gtk-tray.c:30:
/usr/include/glib-2.0/gobject/gtype.h:679:1: note: declared here
  679 | {
      | ^
In file included from /usr/include/gtk-2.0/gtk/gtktoolitem.h:31,
                 from /usr/include/gtk-2.0/gtk/gtktoolbutton.h:30,
                 from /usr/include/gtk-2.0/gtk/gtkmenutoolbutton.h:30,
                 from /usr/include/gtk-2.0/gtk/gtk.h:126,
                 from tomb-gtk-tray.c:30:
/usr/include/gtk-2.0/gtk/gtktooltips.h:73:3: warning: GTimeVal’ is deprecated: Use 'GDateTime' instead []8;;https://gcc.gnu.org/onlinedocs/gcc/Warning-Options.html#index-Wdeprecated-declarations-Wdeprecated-declarations]8;;]
   73 |   GTimeVal last_popdown;
      |   ^~~~~~~~
In file included from /usr/include/glib-2.0/glib/galloca.h:32,
                 from /usr/include/glib-2.0/glib.h:30,
                 from /usr/include/glib-2.0/gobject/gbinding.h:28,
                 from /usr/include/glib-2.0/glib-object.h:22,
                 from /usr/include/glib-2.0/gio/gioenums.h:28,
                 from /usr/include/glib-2.0/gio/giotypes.h:28,
                 from /usr/include/glib-2.0/gio/gio.h:26,
                 from /usr/include/gtk-2.0/gdk/gdkapplaunchcontext.h:30,
                 from /usr/include/gtk-2.0/gdk/gdk.h:32,
                 from /usr/include/gtk-2.0/gtk/gtk.h:32,
                 from tomb-gtk-tray.c:30:
/usr/include/glib-2.0/glib/gtypes.h:547:8: note: declared here
  547 | struct _GTimeVal
      |        ^~~~~~~~~
cc tomb-gtk-tray.o `pkg-config --libs  libnotify gtk+-2.0` -o tomb-gtk-tray
cc -O2 -march=armv7-a -mfloat-abi=hard -mfpu=vfpv3-d16 -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -o tomb-kdb-pbkdf2 pbkdf2.c -lgcrypt
cc -O2 -march=armv7-a -mfloat-abi=hard -mfpu=vfpv3-d16 -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -o tomb-kdb-pbkdf2-getiter benchmark.c -lgcrypt
cc -O2 -march=armv7-a -mfloat-abi=hard -mfpu=vfpv3-d16 -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -o tomb-kdb-pbkdf2-gensalt gen_salt.c -lgcrypt
cc -O2 -march=armv7-a -mfloat-abi=hard -mfpu=vfpv3-d16 -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -o tomb-kdb-hexencode hexencode.c
==> Entering fakeroot environment...
==> Starting package()...
install -Dm755 tomb /build/tomb/pkg/tomb/usr/bin/tomb
install -Dm644 doc/tomb.1 /build/tomb/pkg/tomb/usr/share/man/man1/tomb.1

Tomb is installed succesfully. To install language translations, make sure
gettext is also installed, then 'cd extras/translations' and 'make install' there.

Look around the extras/ directory, it contains other interesting modules.

install -Dm755 tomb-kdb-pbkdf2 /build/tomb/pkg/tomb/usr/bin/tomb-kdb-pbkdf2
install -Dm755 tomb-kdb-pbkdf2-getiter /build/tomb/pkg/tomb/usr/bin/tomb-kdb-pbkdf2-getiter
install -Dm755 tomb-kdb-pbkdf2-gensalt /build/tomb/pkg/tomb/usr/bin/tomb-kdb-pbkdf2-gensalt
install -Dm755 tomb-kdb-hexencode /build/tomb/pkg/tomb/usr/bin/tomb-kdb-hexencode
Tomb-kdb auxiliary binaries installed in /build/tomb/pkg/tomb/usr/bin
==> Tidying install...
  -> Removing libtool files...
  -> Purging unwanted files...
  -> Removing static library files...
  -> Stripping unneeded symbols from binaries and libraries...
  -> Compressing man and info pages...
==> Checking for packaging issues...
==> Creating package "tomb"...
  -> Generating .PKGINFO file...
  -> Generating .BUILDINFO file...
  -> Generating .MTREE file...
  -> Compressing package...
==> Leaving fakeroot environment.
==> Finished making: tomb 2.9-1 (Fri 19 Feb 2021 03:13:43 PM EST)
==> Cleaning up...
==> Removing installed dependencies...
checking dependencies...
:: pinentry optionally requires gtk2: gtk2 backend
warning: dependency cycle detected:
warning: harfbuzz will be removed after its freetype2 dependency

Packages (43) atk-2.36.0-1  avahi-0.8+15+ge8a3dd0-3  cairo-1.17.4-3
              desktop-file-utils-0.26-1  fontconfig-2:2.13.91+48+gfcb0420-2
              freetype2-2.10.4-1  fribidi-1.0.10-1  gdk-pixbuf2-2.42.2-1
              graphite-1:1.3.14-1  gtk-update-icon-cache-1:4.0.3-1
              gtk2-2.24.33-1  harfbuzz-2.7.4-1  hicolor-icon-theme-0.17-2
              libcups-1:2.3.3op2-1  libdaemon-0.14-5  libdatrie-0.2.12-2
              libjpeg-turbo-2.0.6-1  libnotify-0.7.9-1  libpng-1.6.37-3
              librsvg-2:2.50.3-1  libthai-0.1.28-2  libtiff-4.2.0-1
              libx11-1.7.0-3  libxau-1.0.9-3  libxcb-1.14-1
              libxcomposite-0.4.5-3  libxcursor-1.2.0-2  libxdamage-1.1.5-3
              libxdmcp-1.1.3-3  libxext-1.3.4-3  libxfixes-5.0.3-4
              libxft-2.3.3-2  libxi-1.7.10-3  libxinerama-1.1.4-3
              libxrandr-1.5.2-3  libxrender-0.9.10-4  lzo-2.10-3
              pango-1:1.48.2-1  pixman-0.40.0-1
              shared-mime-info-2.0+57+gc1d1c70-1  xcb-proto-1.14.1-3
              xorgproto-2020.1-1  zsh-5.8-1

Total Removed Size:  98.76 MiB

:: Do you want to remove these packages? [Y/n] 
:: Processing package changes...
removing zsh...
removing libnotify...
removing gtk2...
removing libxrandr...
removing libxinerama...
removing libxi...
removing libxdamage...
removing libxcursor...
removing libxcomposite...
removing libxfixes...
removing libcups...
removing gtk-update-icon-cache...
removing librsvg...
removing pango...
removing libxft...
removing libthai...
removing libdatrie...
removing hicolor-icon-theme...
removing gdk-pixbuf2...
removing shared-mime-info...
removing libtiff...
removing libjpeg-turbo...
removing fribidi...
removing desktop-file-utils...
removing cairo...
removing pixman...
removing lzo...
removing libxrender...
removing libxext...
removing libx11...
removing xorgproto...
removing libxcb...
removing xcb-proto...
removing libxdmcp...
removing libxau...
removing fontconfig...
removing freetype2...
removing libpng...
removing harfbuzz...
removing graphite...
removing avahi...
removing libdaemon...
removing atk...
:: Running post-transaction hooks...
(1/3) Reloading system manager configuration...
  Skipped: Current root is not booted.
(2/3) Arming ConditionNeedsUpdate...
(3/3) Reloading system bus configuration...
  Skipped: Current root is not booted.