==> Synchronizing chroot copy [/chroot/i686/root] -> [build]...done
==> Making package: ruby-nokogiri 1.10.10-1 (Wed Sep  9 12:35:11 2020)
==> Retrieving sources...
  -> Found nokogiri-1.10.10.gem
==> Validating source files with sha512sums...
    nokogiri-1.10.10.gem ... Passed
==> Making package: ruby-nokogiri 1.10.10-1 (Wed 09 Sep 2020 12:35:17 PM EDT)
==> Checking runtime dependencies...
==> Installing missing dependencies...
resolving dependencies...
looking for conflicting packages...
warning: dependency cycle detected:
warning: rubygems will be installed before its ruby dependency
warning: dependency cycle detected:
warning: ruby-irb will be installed before its ruby dependency
warning: dependency cycle detected:
warning: ruby-reline will be installed before its ruby dependency

Packages (8) libyaml-0.2.5-1.0  ruby-2.7.1-2.1  ruby-irb-1.2.4-1.0
             ruby-reline-0.1.4-1.0  rubygems-3.1.3-1.0  libxslt-1.1.34-5.2
             ruby-mini_portile2-2.5.0-1.0  ruby-rdoc-6.2.0-2.0

Total Download Size:    5.75 MiB
Total Installed Size:  20.43 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
downloading libyaml-0.2.5-1.0-i686.pkg.tar.zst...
downloading rubygems-3.1.3-1.0-any.pkg.tar.zst...
downloading ruby-2.7.1-2.1-i686.pkg.tar.zst...
downloading libxslt-1.1.34-5.2-i686.pkg.tar.zst...
downloading ruby-reline-0.1.4-1.0-any.pkg.tar.zst...
downloading ruby-irb-1.2.4-1.0-any.pkg.tar.zst...
downloading ruby-mini_portile2-2.5.0-1.0-any.pkg.tar.zst...
downloading ruby-rdoc-6.2.0-2.0-any.pkg.tar.zst...
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
checking available disk space...
:: Processing package changes...
installing libyaml...
installing rubygems...
installing ruby-reline...
installing ruby-irb...
installing ruby...
Optional dependencies for ruby
    ruby-docs: Ruby documentation
    tk: for Ruby/TK
installing ruby-mini_portile2...
installing ruby-rdoc...
installing libxslt...
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found nokogiri-1.10.10.gem
==> WARNING: Skipping all source file integrity checks.
==> Extracting sources...
==> Entering fakeroot environment...
==> Starting package()...
Building native extensions with: '--use-system-libraries'
This could take a while...
Successfully installed nokogiri-1.10.10
Parsing documentation for nokogiri-1.10.10
Installing ri documentation for nokogiri-1.10.10
Done installing documentation for nokogiri after 4 seconds
1 gem installed
==> Tidying install...
  -> Removing empty directories...
  -> Removing libtool files...
  -> Purging unwanted files...
  -> Removing static library files...
  -> Stripping unneeded symbols from binaries and libraries...
  -> Compressing man and info pages...
==> Checking for packaging issues...
==> WARNING: Package contains reference to $pkgdir
usr/lib/ruby/gems/2.7.0/extensions/x86-linux/2.7.0/nokogiri-1.10.10/gem_make.out
==> Creating package "ruby-nokogiri"...
  -> Generating .PKGINFO file...
  -> Generating .BUILDINFO file...
  -> Generating .MTREE file...
  -> Compressing package...
==> Leaving fakeroot environment.
==> Finished making: ruby-nokogiri 1.10.10-1 (Wed 09 Sep 2020 12:36:13 PM EDT)
==> Cleaning up...
==> Removing installed dependencies...
checking dependencies...
warning: dependency cycle detected:
warning: ruby-irb will be removed after its ruby dependency
warning: dependency cycle detected:
warning: ruby-reline will be removed after its ruby dependency
warning: dependency cycle detected:
warning: rubygems will be removed after its ruby dependency

Packages (8) libxslt-1.1.34-5.2  libyaml-0.2.5-1.0  ruby-2.7.1-2.1
             ruby-irb-1.2.4-1.0  ruby-mini_portile2-2.5.0-1.0
             ruby-rdoc-6.2.0-2.0  ruby-reline-0.1.4-1.0  rubygems-3.1.3-1.0

Total Removed Size:  20.43 MiB

:: Do you want to remove these packages? [Y/n] 
:: Processing package changes...
removing ruby-rdoc...
removing ruby-mini_portile2...
removing ruby...
removing rubygems...
removing ruby-irb...
removing ruby-reline...
removing libyaml...
removing libxslt...
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...