==> Synchronizing chroot copy [/chroot/armv8/root] -> [build]...done
==> Making package: python2-pynids 0.6.1-5 (Wed Sep  4 07:58:40 EDT 2019)
==> Retrieving sources...
  -> Found pynids-0.6.1.tar.gz
  -> Found config.guess-for-aarch64.patch
==> Validating source files with sha512sums...
    pynids-0.6.1.tar.gz ... Passed
    config.guess-for-aarch64.patch ... Passed
Host and machine ids are equal (b6eac563832547c9ad9408127b1b4375): refusing to link journals
==> Making package: python2-pynids 0.6.1-5 (Wed 04 Sep 2019 07:58:47 AM EDT)
==> Checking runtime dependencies...
==> Installing missing dependencies...
resolving dependencies...
looking for conflicting packages...

Packages (3) libnsl-1.2.0-1  libnet-1.1.6-3  python2-2.7.16-1

Total Download Size:   11.06 MiB
Total Installed Size:  67.17 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
downloading libnsl-1.2.0-1-aarch64.pkg.tar.xz...
downloading python2-2.7.16-1-aarch64.pkg.tar.xz...
downloading libnet-1.1.6-3-aarch64.pkg.tar.xz...
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
checking available disk space...
:: Processing package changes...
installing libnsl...
installing python2...
Optional dependencies for python2
    tk: for IDLE
    python2-setuptools
    python2-pip
installing libnet...
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found pynids-0.6.1.tar.gz
  -> Found config.guess-for-aarch64.patch
==> WARNING: Skipping all source file integrity checks.
==> Extracting sources...
  -> Extracting pynids-0.6.1.tar.gz with bsdtar
==> Starting prepare()...
patching file setup.py
==> Starting build()...
running build
tar -zxf libnids-1.24.tar.gz
/usr/bin/curl http://git.savannah.gnu.org/cgit/config.git/plain/config.guess -O
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100 48282  100 48282    0     0   173k      0 --:--:-- --:--:-- --:--:--  173k
/usr/bin/curl http://git.savannah.gnu.org/cgit/config.git/plain/config.sub -O
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
 57 31597   57 17988    0     0  94178      0 --:--:-- --:--:-- --:--:-- 94178
100 31597  100 31597    0     0   159k      0 --:--:-- --:--:-- --:--:--  159k
./configure CFLAGS=-fPIC
checking build system type... aarch64-unknown-linux-gnu
checking host system type... aarch64-unknown-linux-gnu
checking target system type... aarch64-unknown-linux-gnu
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for ranlib... ranlib
checking for a BSD-compatible install... /usr/bin/install -c
checking how to run the C preprocessor... gcc -E
checking for egrep... grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking sys/time.h usability... yes
checking sys/time.h presence... yes
checking for sys/time.h... yes
checking syslog.h usability... yes
checking syslog.h presence... yes
checking for syslog.h... yes
checking for unistd.h... (cached) yes
checking for an ANSI C-conforming const... yes
checking for inline... inline
checking whether time.h and sys/time.h may both be included... yes
checking whether byte ordering is bigendian... no
checking for gettimeofday... yes
checking for socket in -lsocket... no
checking for gethostbyname in -lnsl... yes
checking for libpcap... yes
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for GLIB... yes
checking for GTHREAD... yes
checking for g_thread_init in -lgthread-2.0... yes
checking for libnet... yes
checking whether to build shared library... no
checking the name of struct icmp... struct icmphdr
checking if tcp states are defined... yes
checking for bsd-ish struct udphdr... yes
checking libnet version... looks new
configure: creating ./config.status
config.status: creating Makefile
config.status: creating src/Makefile
config.status: creating samples/Makefile
config.status: creating src/config.h
make
cd src ; make  static
make[1]: Entering directory '/build/python2-pynids/src/pynids-0.6.1/libnids-1.24/src'
gcc -c -fPIC -D_BSD_SOURCE -DLIBNET_VER=1 -DHAVE_ICMPHDR=1 -DHAVE_TCP_STATES=1 -DHAVE_BSD_UDPHDR=1 -I. -I/usr/include/pcap -D_BSD_SOURCE -D__BSD_SOURCE -D__FAVOR_BSD -DHAVE_NET_ETHERNET_H -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include  -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include  checksum.c
In file included from /usr/include/sys/types.h:25,
                 from checksum.c:2:
/usr/include/features.h:185:3: warning: #warning "_BSD_SOURCE and _SVID_SOURCE are deprecated, use _DEFAULT_SOURCE" [-Wcpp]
 # warning "_BSD_SOURCE and _SVID_SOURCE are deprecated, use _DEFAULT_SOURCE"
   ^~~~~~~
gcc -c -fPIC -D_BSD_SOURCE -DLIBNET_VER=1 -DHAVE_ICMPHDR=1 -DHAVE_TCP_STATES=1 -DHAVE_BSD_UDPHDR=1 -I. -I/usr/include/pcap -D_BSD_SOURCE -D__BSD_SOURCE -D__FAVOR_BSD -DHAVE_NET_ETHERNET_H -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include  -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include  ip_fragment.c
In file included from /usr/include/sys/types.h:25,
                 from ip_fragment.c:7:
/usr/include/features.h:185:3: warning: #warning "_BSD_SOURCE and _SVID_SOURCE are deprecated, use _DEFAULT_SOURCE" [-Wcpp]
 # warning "_BSD_SOURCE and _SVID_SOURCE are deprecated, use _DEFAULT_SOURCE"
   ^~~~~~~
gcc -c -fPIC -D_BSD_SOURCE -DLIBNET_VER=1 -DHAVE_ICMPHDR=1 -DHAVE_TCP_STATES=1 -DHAVE_BSD_UDPHDR=1 -I. -I/usr/include/pcap -D_BSD_SOURCE -D__BSD_SOURCE -D__FAVOR_BSD -DHAVE_NET_ETHERNET_H -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include  -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include  ip_options.c
In file included from /usr/include/bits/libc-header-start.h:33,
                 from /usr/include/string.h:26,
                 from ip_options.c:6:
/usr/include/features.h:185:3: warning: #warning "_BSD_SOURCE and _SVID_SOURCE are deprecated, use _DEFAULT_SOURCE" [-Wcpp]
 # warning "_BSD_SOURCE and _SVID_SOURCE are deprecated, use _DEFAULT_SOURCE"
   ^~~~~~~
gcc -c -fPIC -D_BSD_SOURCE -DLIBNET_VER=1 -DHAVE_ICMPHDR=1 -DHAVE_TCP_STATES=1 -DHAVE_BSD_UDPHDR=1 -I. -I/usr/include/pcap -D_BSD_SOURCE -D__BSD_SOURCE -D__FAVOR_BSD -DHAVE_NET_ETHERNET_H -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include  -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include  killtcp.c
In file included from /usr/include/sys/types.h:25,
                 from killtcp.c:7:
/usr/include/features.h:185:3: warning: #warning "_BSD_SOURCE and _SVID_SOURCE are deprecated, use _DEFAULT_SOURCE" [-Wcpp]
 # warning "_BSD_SOURCE and _SVID_SOURCE are deprecated, use _DEFAULT_SOURCE"
   ^~~~~~~
gcc -c -fPIC -D_BSD_SOURCE -DLIBNET_VER=1 -DHAVE_ICMPHDR=1 -DHAVE_TCP_STATES=1 -DHAVE_BSD_UDPHDR=1 -I. -I/usr/include/pcap -D_BSD_SOURCE -D__BSD_SOURCE -D__FAVOR_BSD -DHAVE_NET_ETHERNET_H -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include  -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include  libnids.c
In file included from /usr/include/sys/types.h:25,
                 from libnids.c:7:
/usr/include/features.h:185:3: warning: #warning "_BSD_SOURCE and _SVID_SOURCE are deprecated, use _DEFAULT_SOURCE" [-Wcpp]
 # warning "_BSD_SOURCE and _SVID_SOURCE are deprecated, use _DEFAULT_SOURCE"
   ^~~~~~~
libnids.c: In function ‘open_live’:
libnids.c:512:2: warning: ‘pcap_lookupdev’ is deprecated: use 'pcap_findalldevs' and use the first device [-Wdeprecated-declarations]
  nids_params.device = pcap_lookupdev(nids_errbuf);
  ^~~~~~~~~~~
In file included from libnids.c:18:
/usr/include/pcap/pcap.h:326:16: note: declared here
 PCAP_API char *pcap_lookupdev(char *)
                ^~~~~~~~~~~~~~
libnids.c: In function ‘nids_init’:
libnids.c:672:3: warning: ‘g_thread_init’ is deprecated [-Wdeprecated-declarations]
   g_thread_init(NULL);
   ^~~~~~~~~~~~~
In file included from /usr/include/glib-2.0/glib.h:111,
                 from libnids.c:32:
/usr/include/glib-2.0/glib/deprecated/gthread.h:265:10: note: declared here
 void     g_thread_init                   (gpointer vtable);
          ^~~~~~~~~~~~~
libnids.c: In function ‘nids_run’:
libnids.c:689:5: warning: ‘g_thread_create_full’ is deprecated: Use 'g_thread_new' instead [-Wdeprecated-declarations]
     START_CAP_QUEUE_PROCESS_THREAD(); /* threading... */
     ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
In file included from /usr/include/glib-2.0/glib.h:111,
                 from libnids.c:32:
/usr/include/glib-2.0/glib/deprecated/gthread.h:110:10: note: declared here
 GThread *g_thread_create_full  (GThreadFunc       func,
          ^~~~~~~~~~~~~~~~~~~~
libnids.c: In function ‘nids_next’:
libnids.c:749:5: warning: ‘g_thread_create_full’ is deprecated: Use 'g_thread_new' instead [-Wdeprecated-declarations]
     START_CAP_QUEUE_PROCESS_THREAD();
     ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
In file included from /usr/include/glib-2.0/glib.h:111,
                 from libnids.c:32:
/usr/include/glib-2.0/glib/deprecated/gthread.h:110:10: note: declared here
 GThread *g_thread_create_full  (GThreadFunc       func,
          ^~~~~~~~~~~~~~~~~~~~
libnids.c: In function ‘nids_dispatch’:
libnids.c:763:5: warning: ‘g_thread_create_full’ is deprecated: Use 'g_thread_new' instead [-Wdeprecated-declarations]
     START_CAP_QUEUE_PROCESS_THREAD(); /* threading... */
     ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
In file included from /usr/include/glib-2.0/glib.h:111,
                 from libnids.c:32:
/usr/include/glib-2.0/glib/deprecated/gthread.h:110:10: note: declared here
 GThread *g_thread_create_full  (GThreadFunc       func,
          ^~~~~~~~~~~~~~~~~~~~
gcc -c -fPIC -D_BSD_SOURCE -DLIBNET_VER=1 -DHAVE_ICMPHDR=1 -DHAVE_TCP_STATES=1 -DHAVE_BSD_UDPHDR=1 -I. -I/usr/include/pcap -D_BSD_SOURCE -D__BSD_SOURCE -D__FAVOR_BSD -DHAVE_NET_ETHERNET_H -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include  -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include  scan.c
In file included from /usr/include/sys/types.h:25,
                 from scan.c:6:
/usr/include/features.h:185:3: warning: #warning "_BSD_SOURCE and _SVID_SOURCE are deprecated, use _DEFAULT_SOURCE" [-Wcpp]
 # warning "_BSD_SOURCE and _SVID_SOURCE are deprecated, use _DEFAULT_SOURCE"
   ^~~~~~~
gcc -c -fPIC -D_BSD_SOURCE -DLIBNET_VER=1 -DHAVE_ICMPHDR=1 -DHAVE_TCP_STATES=1 -DHAVE_BSD_UDPHDR=1 -I. -I/usr/include/pcap -D_BSD_SOURCE -D__BSD_SOURCE -D__FAVOR_BSD -DHAVE_NET_ETHERNET_H -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include  -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include  tcp.c
In file included from /usr/include/sys/types.h:25,
                 from tcp.c:7:
/usr/include/features.h:185:3: warning: #warning "_BSD_SOURCE and _SVID_SOURCE are deprecated, use _DEFAULT_SOURCE" [-Wcpp]
 # warning "_BSD_SOURCE and _SVID_SOURCE are deprecated, use _DEFAULT_SOURCE"
   ^~~~~~~
gcc -c -fPIC -D_BSD_SOURCE -DLIBNET_VER=1 -DHAVE_ICMPHDR=1 -DHAVE_TCP_STATES=1 -DHAVE_BSD_UDPHDR=1 -I. -I/usr/include/pcap -D_BSD_SOURCE -D__BSD_SOURCE -D__FAVOR_BSD -DHAVE_NET_ETHERNET_H -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include  -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include  util.c
In file included from /usr/include/sys/types.h:25,
                 from util.c:7:
/usr/include/features.h:185:3: warning: #warning "_BSD_SOURCE and _SVID_SOURCE are deprecated, use _DEFAULT_SOURCE" [-Wcpp]
 # warning "_BSD_SOURCE and _SVID_SOURCE are deprecated, use _DEFAULT_SOURCE"
   ^~~~~~~
gcc -c -fPIC -D_BSD_SOURCE -DLIBNET_VER=1 -DHAVE_ICMPHDR=1 -DHAVE_TCP_STATES=1 -DHAVE_BSD_UDPHDR=1 -I. -I/usr/include/pcap -D_BSD_SOURCE -D__BSD_SOURCE -D__FAVOR_BSD -DHAVE_NET_ETHERNET_H -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include  -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include  allpromisc.c
In file included from /usr/include/sys/types.h:25,
                 from nids.h:9,
                 from allpromisc.c:1:
/usr/include/features.h:185:3: warning: #warning "_BSD_SOURCE and _SVID_SOURCE are deprecated, use _DEFAULT_SOURCE" [-Wcpp]
 # warning "_BSD_SOURCE and _SVID_SOURCE are deprecated, use _DEFAULT_SOURCE"
   ^~~~~~~
gcc -c -fPIC -D_BSD_SOURCE -DLIBNET_VER=1 -DHAVE_ICMPHDR=1 -DHAVE_TCP_STATES=1 -DHAVE_BSD_UDPHDR=1 -I. -I/usr/include/pcap -D_BSD_SOURCE -D__BSD_SOURCE -D__FAVOR_BSD -DHAVE_NET_ETHERNET_H -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include  -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include  hash.c
In file included from /usr/include/sys/types.h:25,
                 from hash.c:1:
/usr/include/features.h:185:3: warning: #warning "_BSD_SOURCE and _SVID_SOURCE are deprecated, use _DEFAULT_SOURCE" [-Wcpp]
 # warning "_BSD_SOURCE and _SVID_SOURCE are deprecated, use _DEFAULT_SOURCE"
   ^~~~~~~
ar -cr libnids.a checksum.o ip_fragment.o ip_options.o killtcp.o libnids.o scan.o tcp.o util.o allpromisc.o hash.o
ranlib libnids.a
make[1]: Leaving directory '/build/python2-pynids/src/pynids-0.6.1/libnids-1.24/src'
running build_ext
building 'nidsmodule' extension
creating build
creating build/temp.linux-aarch64-2.7
gcc -pthread -DNDEBUG -march=armv8-a -O2 -pipe -fstack-protector-strong -fno-plt -march=armv8-a -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2 -fPIC -Ilibnids-1.24/src -I/usr/local/include -I/opt/local/include -I/usr/include/python2.7 -c nidsmodule.c -o build/temp.linux-aarch64-2.7/nidsmodule.o
creating build/lib.linux-aarch64-2.7
gcc -pthread -shared -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now -Wl,-O1,--sort-common,--as-needed,-z,relro -march=armv8-a -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2 build/temp.linux-aarch64-2.7/nidsmodule.o libnids-1.24/src/libnids.a -L/usr/local/lib -L/opt/local/lib -L/usr/lib -lpcap -lnet -lglib-2.0 -lgthread-2.0 -lpython2.7 -o build/lib.linux-aarch64-2.7/nidsmodule.so
==> Entering fakeroot environment...
==> Starting package()...
running install
running build
running build_ext
running install_lib
creating /build/python2-pynids/pkg/python2-pynids/usr
creating /build/python2-pynids/pkg/python2-pynids/usr/lib
creating /build/python2-pynids/pkg/python2-pynids/usr/lib/python2.7
creating /build/python2-pynids/pkg/python2-pynids/usr/lib/python2.7/site-packages
copying build/lib.linux-aarch64-2.7/nidsmodule.so -> /build/python2-pynids/pkg/python2-pynids/usr/lib/python2.7/site-packages
running install_egg_info
Writing /build/python2-pynids/pkg/python2-pynids/usr/lib/python2.7/site-packages/pynids-0.6.1-py2.7.egg-info
==> Tidying install...
  -> Removing libtool files...
  -> Purging unwanted files...
  -> Removing static library files...
  -> Stripping unneeded symbols from binaries and libraries...
  -> Compressing man and info pages...
==> Checking for packaging issues...
==> Creating package "python2-pynids"...
  -> Generating .PKGINFO file...
  -> Generating .BUILDINFO file...
  -> Generating .MTREE file...
  -> Compressing package...
==> Leaving fakeroot environment.
==> Finished making: python2-pynids 0.6.1-5 (Wed 04 Sep 2019 07:59:49 AM EDT)
==> Cleaning up...
==> Removing installed dependencies...
checking dependencies...

Packages (3) libnet-1.1.6-3  libnsl-1.2.0-1  python2-2.7.16-1

Total Removed Size:  67.17 MiB

:: Do you want to remove these packages? [Y/n] 
:: Processing package changes...
removing python2...
removing libnsl...
removing libnet...
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...