==> Synchronizing chroot copy [/chroot/x86_64/root] -> [build]...done
==> Making package: frida 15.1.17-1 (Wed Feb 16 17:52:46 2022)
==> Retrieving sources...
  -> Found frida-15.1.17.tar.gz
  -> Found COPYING
==> WARNING: Skipping verification of source file PGP signatures.
==> Validating source files with sha512sums...
    frida-15.1.17.tar.gz ... Passed
    COPYING ... Passed
==> Making package: frida 15.1.17-1 (Wed 16 Feb 2022 05:53:09 PM EST)
==> Checking runtime dependencies...
==> Installing missing dependencies...
[?25lresolving dependencies...
looking for conflicting packages...

Packages (13) libnsl-2.0.0-2  python-3.10.2-1  python-appdirs-1.4.4-6
              python-more-itertools-8.10.0-4  python-ordered-set-4.0.2-6
              python-packaging-20.9-7  python-pyparsing-2.4.7-6
              python-setuptools-1:59.3.0-1  python-six-1.16.0-5
              python-wcwidth-0.2.5-6  python-colorama-0.4.4-6
              python-prompt_toolkit-3.0.28-1  python-pygments-2.11.2-1

Total Download Size:    3.49 MiB
Total Installed Size:  73.59 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
 python-pygments-2.11.2-1-any downloading...
 python-prompt_toolkit-3.0.28-1-any downloading...
 python-setuptools-1:59.3.0-1-any downloading...
 python-pyparsing-2.4.7-6-any downloading...
 python-more-itertools-8.10.0-4-any downloading...
 python-packaging-20.9-7-any downloading...
 python-wcwidth-0.2.5-6-any downloading...
 python-colorama-0.4.4-6-any downloading...
 python-six-1.16.0-5-any downloading...
 python-appdirs-1.4.4-6-any downloading...
 python-ordered-set-4.0.2-6-any downloading...
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
checking available disk space...
:: Processing package changes...
installing libnsl...
installing python...
Optional dependencies for python
    python-setuptools [pending]
    python-pip
    sqlite [installed]
    mpdecimal: for decimal
    xz: for lzma [installed]
    tk: for tkinter
installing python-colorama...
installing python-appdirs...
installing python-more-itertools...
installing python-ordered-set...
installing python-pyparsing...
installing python-six...
installing python-packaging...
installing python-setuptools...
installing python-pygments...
installing python-wcwidth...
installing python-prompt_toolkit...
[?25h==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found frida-15.1.17.tar.gz
  -> Found COPYING
==> WARNING: Skipping all source file integrity checks.
==> Extracting sources...
  -> Extracting frida-15.1.17.tar.gz with bsdtar
==> Starting build()...
running build
running build_py
creating build
creating build/lib.linux-x86_64-3.10
creating build/lib.linux-x86_64-3.10/frida
copying frida/core.py -> build/lib.linux-x86_64-3.10/frida
copying frida/__init__.py -> build/lib.linux-x86_64-3.10/frida
running build_ext
looking for prebuilt extension in home directory, i.e. /build/frida-15.1.17-py3.10-linux-x86_64.egg
prebuilt extension not found in home directory, will try downloading it
querying pypi for available prebuilds
using default index URL: https://pypi.org/simple/
downloading package list from https://pypi.org/simple/frida/
downloading prebuilt extension from https://files.pythonhosted.org/packages/4c/98/439ca2df99ae4a6b816f2306884309e9b92216d7d86b8450170f0d12919b/frida-15.1.17-py3.8-linux-x86_64.egg#sha256=b98410aea599404d8e46b687bac570e1229f06e17a89cd617eb642c79370e28c
checking hash
extracting prebuilt extension
==> Entering fakeroot environment...
==> Starting package()...
running install
/usr/lib/python3.10/site-packages/setuptools/command/install.py:34: SetuptoolsDeprecationWarning: setup.py install is deprecated. Use build and pip and other standards-based tools.
  warnings.warn(
running install_lib
creating /build/frida/pkg/frida/usr
creating /build/frida/pkg/frida/usr/lib
creating /build/frida/pkg/frida/usr/lib/python3.10
creating /build/frida/pkg/frida/usr/lib/python3.10/site-packages
creating /build/frida/pkg/frida/usr/lib/python3.10/site-packages/frida
copying build/lib.linux-x86_64-3.10/frida/core.py -> /build/frida/pkg/frida/usr/lib/python3.10/site-packages/frida
copying build/lib.linux-x86_64-3.10/frida/__init__.py -> /build/frida/pkg/frida/usr/lib/python3.10/site-packages/frida
copying build/lib.linux-x86_64-3.10/_frida.cpython-310-x86_64-linux-gnu.so -> /build/frida/pkg/frida/usr/lib/python3.10/site-packages
byte-compiling /build/frida/pkg/frida/usr/lib/python3.10/site-packages/frida/core.py to core.cpython-310.pyc
byte-compiling /build/frida/pkg/frida/usr/lib/python3.10/site-packages/frida/__init__.py to __init__.cpython-310.pyc
writing byte-compilation script '/tmp/tmpv5r4rqa2.py'
/usr/bin/python -Wignore:The distutils package is deprecated and slated for removal in Python 3.12. Use setuptools or check PEP 632 for potential alternatives:DeprecationWarning /tmp/tmpv5r4rqa2.py
removing /tmp/tmpv5r4rqa2.py
running install_egg_info
running egg_info
writing frida.egg-info/PKG-INFO
writing dependency_links to frida.egg-info/dependency_links.txt
writing requirements to frida.egg-info/requires.txt
writing top-level names to frida.egg-info/top_level.txt
reading manifest file 'frida.egg-info/SOURCES.txt'
adding license file 'COPYING'
writing manifest file 'frida.egg-info/SOURCES.txt'
Copying frida.egg-info to /build/frida/pkg/frida/usr/lib/python3.10/site-packages/frida-15.1.17-py3.10.egg-info
running install_scripts
==> Tidying install...
  -> Removing libtool files...
  -> Purging unwanted files...
  -> Removing static library files...
  -> Stripping unneeded symbols from binaries and libraries...
  -> Compressing man and info pages...
==> Checking for packaging issues...
==> Creating package "frida"...
  -> Generating .PKGINFO file...
  -> Generating .BUILDINFO file...
  -> Generating .MTREE file...
  -> Compressing package...
==> Leaving fakeroot environment.
==> Finished making: frida 15.1.17-1 (Wed 16 Feb 2022 05:54:40 PM EST)
==> Cleaning up...
==> Removing installed dependencies...
[?25lchecking dependencies...
:: glib2 optionally requires python: gdbus-codegen, glib-genmarshal, glib-mkenums, gtester-report
:: util-linux optionally requires python: python bindings to libmount

Packages (13) libnsl-2.0.0-2  python-3.10.2-1  python-appdirs-1.4.4-6
              python-colorama-0.4.4-6  python-more-itertools-8.10.0-4
              python-ordered-set-4.0.2-6  python-packaging-20.9-7
              python-prompt_toolkit-3.0.28-1  python-pygments-2.11.2-1
              python-pyparsing-2.4.7-6  python-setuptools-1:59.3.0-1
              python-six-1.16.0-5  python-wcwidth-0.2.5-6

Total Removed Size:  73.59 MiB

:: Do you want to remove these packages? [Y/n] 
:: Processing package changes...
removing python-prompt_toolkit...
removing python-wcwidth...
removing python-pygments...
removing python-setuptools...
removing python-packaging...
removing python-six...
removing python-pyparsing...
removing python-ordered-set...
removing python-more-itertools...
removing python-colorama...
removing python-appdirs...
removing python...
removing libnsl...
[?25h